Sending emails to inbox is out of service
Incident Report for Zenegy
Resolved
This incident has been resolved.
Posted Sep 02, 2024 - 08:44 CEST
Update
We are continuing to investigate this issue.
Posted Sep 02, 2024 - 08:40 CEST
Investigating
Sending emails to inbox is out of service - we are working on resolving the issue.
Posted Aug 29, 2024 - 12:02 CEST
This incident affected: Zenegy Expense (Expense - Web, Expense - Mobilapp) and Zenegy Numbers (Numbers - Web, Numbers - 3. part).