Increased loading times
Incident Report for Zenegy
Resolved
This incident has been resolved.
Posted Aug 29, 2024 - 12:30 CEST
Monitoring
A fix has been implemented, and we are monitoring the result.
Posted Aug 29, 2024 - 11:36 CEST
Investigating
We are currently experiencing increased loading times in the Expense app on both iOS and Android.
The loading might get stuck at the spinning wheel. In that case, please try to restart the app.

We appreciate your understanding and apologize for any inconvenience this may cause.
Posted Aug 29, 2024 - 09:08 CEST
This incident affected: Zenegy Expense (Expense - Mobilapp).